Email issues
Incident Report for Citrus Telecom
Resolved
This incident has been resolved.
Posted Jan 26, 2019 - 10:09 GMT
Identified
We are currently having an issue with emails due to a problem with Microsoft 365 affecting many companies worldwide.
This means that tickets and emails may not get through. If your email or ticket is urgent please call the office on 03451939393.
Posted Jan 24, 2019 - 12:47 GMT