DDoS Attack
Incident Report for Citrus Telecom
Resolved
This incident has been resolved.
Posted Sep 19, 2020 - 22:30 BST
Monitoring
Citrus network has been under attack from hackers last 2 days:
We are working on the solution, and right now we understand the hack has been blocked.
Sorry for any inconvenience caused during this time.
Posted Sep 19, 2020 - 12:36 BST
Update
We are continuing to work on a fix for this issue.
Posted Sep 19, 2020 - 09:43 BST
Identified
Citrus Telecom are experiencing a determined hacking attack. We are managing this in real time by blocking attacks across our network.
Posted Sep 19, 2020 - 09:42 BST
This incident affected: TDM Interconnects, Retail Telephony Platform, Core IP network, Internet access, xDSL, GEA, FTTC, Fibre Ethernet, SIP Trunking / phone line replacement service, API, CDR, VPN services, CPS, IDA and NTS, DigiDesk, and ECT Platform.