Unexpected Outage
Incident Report for Citrus Telecom
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 17:00 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 30, 2019 - 11:18 GMT
This incident affected: Internet access, xDSL, GEA, FTTC, Fibre Ethernet and SIP Trunking / phone line replacement service.