Broadband Blip
Incident Report for Citrus Telecom
Resolved
This incident has been resolved.
Posted Mar 21, 2019 - 18:02 GMT
Update
Broadband issue is now resolved.
Posted Mar 21, 2019 - 15:54 GMT
Monitoring
We have seen that most customers are now reconnected, if your service is not reconnected please disconnect power to your router and reconnect. We are continuing to monitor this issue.
Posted Mar 21, 2019 - 11:54 GMT
Investigating
We have noticed some lines disconnecting at around 11:21, our provider is aware of the issue and we are now starting to see lines reconnect.
Posted Mar 21, 2019 - 11:52 GMT
This incident affected: Internet access, xDSL, GEA, FTTC, Fibre Ethernet.