Potential BT Outage
Incident Report for Citrus Telecom
Resolved
This incident has been resolved.
Posted May 22, 2019 - 09:31 BST
Update
BT have cleared their status page now, after acknowledging there was a BT Mobile outage, we will monitor.
Posted May 21, 2019 - 17:30 BST
Investigating
We are aware of a potential BT/BT Mobile outage which maybe affecting some Citrus services TBC.
Posted May 21, 2019 - 14:00 BST
This incident affected: Retail Telephony Platform.