IDA codes not reachable from some locations
Incident Report for Citrus Telecom
Resolved
Supplier confirms this has now been resolved.
Posted Jan 16, 2017 - 15:30 GMT
Investigating
We have a fault with IDA codes, where calls from some areas of the UK do not reach us. This is currently under investigation with our transit supplier for these codes.
Posted Jan 16, 2017 - 10:16 GMT