Power issue in London DC
Incident Report for Citrus Telecom
Resolved
This incident is now resolved. Customers who require RFO should please open a ticket if you have not already opened one. We apologise for any inconvenience this issue caused.
Posted Oct 18, 2018 - 08:08 BST
Monitoring
This issue has now been resolved, the replacement equipment has been installed and is operating. We are now monitoring.
Posted Oct 16, 2018 - 00:44 BST
Update
Due to the damage caused by the internal power supply failure, the equipment is beyond repair and replacement hardware is now being sent to the London Data Center to restore service.
Posted Oct 15, 2018 - 16:10 BST
Update
Engineers are currently onsite working on the issues with our TDM interconnects, the fault has been identified and is being worked on.
Posted Oct 15, 2018 - 11:19 BST
Update
Most services have now recovered, but we have reduced capacity on our BT interconnects, this is being investigated now.
Posted Oct 15, 2018 - 09:47 BST
Update
We are seeing calls starting to process at our London site, and are working to fully restore service
Posted Oct 15, 2018 - 09:24 BST
Identified
We have had a power issue at our London DC with multiple breakers tripped. These have now been corrected, the cause of the issue is under investigation, in the meantime some calls are not connecting while the affected services are restarted. We apologise for the disuption
Posted Oct 15, 2018 - 09:18 BST
This incident affected: TDM Interconnects, Retail Telephony Platform, and CPS, IDA and NTS.